当前位置:新闻动态 \ 行业动态
路由器漏洞CVE-2018-14847危险系数升级,可提供完全的根访问权限
新闻来源:黑客视界
发布人:计算机安全协会
点击率:169
发布日期:2018.10.11

 

社交新闻网站Hacker News于本周一(10月8日)发表的一篇文章来看,一个早在几个月前就已经被公开披露的MikroTik路由器漏洞的危险系数可能比最初的评定结果要高得多。

这个漏洞被追踪为CVE-2018-14847,是一个在今年4月份被发现并在同一天被修复的目录遍历漏洞,其危险程度最初被评定为“Medium”。它的存在使得远程攻击者能够通过修改请求来绕过身份验证,并读取任意文件。

然而,从最新公布的研究成果来看,它的危险程序似乎远不止于此。因为,针对受该漏洞影响的MikroTik路由器开发的最新漏洞利用脚本允许攻击者远程执行任意代码,并获得一个root shell。因此,它的危险程度似乎应该被评定为“Critical”,而不是“Medium”。

新的漏洞利用脚本将“Medium”升级至“Critical”

就在上周日(10月7日),来自全球知名高科技网络安全公司Tenable的安全研究人员Jacob Baines针对CVE-2018-14847发布了一段新的概念验证(PoC)代码,实现了在受漏洞影响的MikroTik路由器上的远程代码执行。

这段代码被Jacob Baines发布在Github上,并命名为“By the Way”。漏洞利用涉及到首先使用目录遍历漏洞从用户数据库文件中窃取管理员登录凭证,然后在系统上写另一个文件,远程获取root shell访问权限。

换句话来说,新的漏洞利用脚本可能允许未经授权的攻击者侵入MikroTik的RouterOS系统,部署恶意软件有效载荷或绕过路由器防火墙保护。

这项新的攻击技术可以说是对MikroTik路由器安全性的又一次打击。之前该路由器曾被复杂的规模化恶意软件VPNFilter盯上,而CVE-2018-14847也在几个月前被揭露的一场大规模加密货币挖掘活动中遭到了利用。

Tenable还公布了更多新的MikroTik路由器漏洞

除此之外,Tenable在上周日发表的博文中还公开披露了其他几个新的MikroTik RouterOS漏洞,这包括:

  • CVE-2018-1156——堆栈缓冲区溢出漏洞,允许通过身份验证的远程代码执行,使得攻击者能够获得完整的系统访问权限并访问路由器的所有内部系统;

  • CVE-2018-1157——文件上传内存耗尽漏洞,允许经过身份验证的远程攻击者导致HTTP服务器崩溃;

  • CVE-2018-1159——www内存损坏漏洞,使得攻击者能够通过快速的身份验证和断开连接来导致HTTP服务器崩溃;

  • CVE-2018-1158——递归解析栈耗尽漏洞,使得攻击者能够通过JSON的递归解析来导致HTTP服务器崩溃。

根据Tenable的说法,以上这些漏洞能够影响到6.42.7以及6.40.9之前的所有Mikrotik RouterOS固件版本。

Tenable表示,他们早在5月份就已经向MikroTik通报了这些漏洞的存在,而该公司也在8月份发布了其RouterOS版本6.40.9、6.42.7和6.43,以解决这些漏洞。

尽管所有这些漏洞都在一个月前得到了修复,但Tenable最近的一次扫描显示,70%受漏洞影响的MikroTik路由器(大约20万台)仍然容易受到攻击。

上一篇:研究人员表示英特尔安全声明就是个“厚颜无耻的谎言”
下一篇:APT28干回“老本行”,针对多个国家的军事、政府进行情报收集
【打印此页】【返回顶部】【关闭本页】
宁波市计算机信息网络安全协会   版权所有 2011-2016   ICP备案号:浙ICP备06028402号   网站维护商:宁波公众
联系电话:0574-87815766/87815706    传真:0574-87815706
EMAIL:nbaqxh@163.com